Servidores LiteSpeed con HTTP2, PHP7 y LiteSpeed Cache

leer

Servidores LiteSpeed con HTTP2, PHP7 y LiteSpeed Cache

| Última Modificación: 24 septiembre, 2017 a las 2:00 pm

Servidores LiteSpeed con HTTP2, PHP7 y LiteSpeed Cache

Queremos informarte de algunos cambios que hemos llevado a cabo en las últimas semanas, en relación al hosting compartido. Durante todo el verano, hemos venido realizando pruebas para mejorar el servicio de alojamiento web que ofrecemos a nuestros clientes. Estas pruebas han sido muy satisfactorias y las hemos terminado aplicando en nuestros servidores en producción, cambiando nuestros servidores web por LiteSpeed.

Desde hoy, todos nuestros servidores presentan las siguientes novedades:

 

SERVIDORES LITESPEED

El servidor web que sirve ahora todas las páginas de nuestros clientes es LiteSpeed. Este servidor, supone una mejora sustancial en el tiempo de carga de las páginas, llegando a alcanzar velocidades de vértigo en los sitios que estén bien desarrollados (imágenes optimizadas, javascript y css comprimidos, etc). Algunas páginas de clientes cargan ahora desde España en menos de ¡0,5 segundos!. Es el mejor servidor web del mercado, muy por encima de Apache y Nginx. Es por tanto un paso adelante en la calidad que ofrecemos en nuestros hostings. ya que muy pocos proveedores en el mundo lo ofrecen. Posiblemente debido al alto precio de sus licencias. Nosotros, además de ofrecerlo sin aumento de coste en todos los planes de hosting compartido, nos hemos convertido en Partner de Litespeed por lo que las ofrecemos también a nuestros clientes de VPS y Dedicados.

Si encuentras que tu web carga lenta, puedes seguir algunas recomendaciones para mejorar esa velocidad como las que aconseja Google Pagespeed.

También puedes enviarnos un ticket de soporte para ayudarte a optimizar tu web, estaremos encantados de ayudarte a que tu web vuele.

 

VERSIÓN PHP 7

Posibilidad de usar varias versiones de php, incluida la nueva versión PHP 7.

Si tienes un WordPress 4.4 ó superior o un Joomla 3.5 o superior, te recomendamos usar la versión PHP 7 en tu web. ¡Cámbiala ahora y verás la mejora de velocidad!
Estas versiones soportan la versión 7 de php, pero algunos plugins o componentes puede que no. Si tienes estas versiones de WordPress ó Joomla y al cambiar a PHP7 ves algún error en tu web, deberás bajar a la versión 5.6 (inherit).  La verás en la selección de versiones de PHP y buscar actualizaciones para esos plugins o componentes que te fallan.

¿Cómo puedo cambiar la versión de php en mi hosting? Muy fácil, solo debes entrar a tu panel de control cPanel. Seleccionar la opción “Administrador MultiPHP” y elegir el dominio o subdominios. Seleccionar del desplegable la versión que quieres activar y darle al botón aplicar, tal que así:

 

Activación de PHP7

Cómo activar php7 en cPanel

 

Las versiones de php que se pueden seleccionar ahora son las siguientes:

 

VERSIÓN PHP 5.3

– 5.3. Esta versión ya no recibe soporte ni actualizaciones de seguridad por parte del equipo de PHP. Aunque la mantendremos activa hasta Abril de 2017 ya que muchos clientes tienen páginas antiguas que no funcionan con otra versión.

Es muy importante que actualices de versión tu web si está desarrollada con Joomla.  A partir del 1 de Octubre de 2017 no funcionará en nuestros servidores. Las versiones de Joomla 1.0.x, Joomla 1.5.x y Joomla 1.7 dejarán de funcionar.

Hay clientes que tienen páginas web con versiones de Joomla que tienen más de 10 años.  ¡OJO! No daremos soporte ni mantenimiento a estas páginas a partir de Abril de 2017. Te aconsejamos que compruebes de la versión de tu web para antes de esa fecha tenerla actualizada. Mantener estas páginas supone un riesgo de seguridad para todo el servidor y por tanto para los demás clientes. Además que nos impiden a desarrollar mejoras en nuestros servidores.

Si tienes una web con estas versiones deberás activar la versión 5.3 en tu hosting. A algunos clientes ya se la hemos activado al comprobar que no funcionaban en nuestras pruebas.

¿Cómo puedo activar la versión 5.3 en mi hosting?

Para activar la versión 5.3 en tu hosting debes seleccionar la opción “inherit” en la opción “Administrador MultiPHP”. Activar la versión 5.3 en la opción especial “PHP Selector”, activando y guardando antes los módulos con la opción “usar predeterminado“.

OJO: Si tu web funciona bien ahora mismo no debes seleccionar esta versión 5.3, solo es para webs antiguas que ahora mismo no carguen bien o den errores.

 

OTRAS VERSIONES DE PHP

– 5.4
– 5.5
– 5.6 (la versión habilitada por defecto para todo el servidor)
– 7.0
– 7.1

 

A partir del 1 de Octubre de 2017, la versión de php 5.3 no estará disponible en nuestros servidores.

 

VALORES PERSONALIZADOS PHP

Posibilidad de crear un php.ini personalizado para cambiar parámetros php por defecto.

A veces, por necesidades de algún plugin, necesitamos que algunos parámetros del php sean aumentados para hacerlo funcionar correctamente. Antes usábamos la opción de crear un “.user.ini” en el raíz del hosting para activarlos. AHORA ESTO HA CAMBIADO. Para dar de alta cambios en el php de forma personalizada, debemos crearlos en un archivo llamado “php.ini” que ubicaremos en la carpeta “home” de nuestro hosting (no dentro de public_html como antes). Los clientes que tenían ya configurado un “.user.ini” personalizado para las necesidades de su hosting ahora lo tienen en un php.ini que hemos creado con los mismos parámetros anteriores.

Otra opción es modificar los valores del php.ini o crearlo desde la opción que ahora existe en cPanel para ello. Lo haremos desde “Editor INI de MultiPHP“. Para que funcionen nuestros cambios deberemos simpre seleccionar en el desplegable la opción de “Home Directory”.

No queremos hacer muy largo este email con muchos detalles técnicos así que en próximos días subiremos un manual más detallado con capturas de cómo hacerlo o bien os enviaremos un email informativo. Cualquier duda, como siempre, en Soporte os atenderemos.

 

HTTP/2

Esto sí que es un superavance para todos nuestros clientes. El nuevo protocolo HTTP/2 está soportado en nuestros servidores de LiteSpeed. Debes dar de alta un certificado SSL de los que ofrecemos gratuitos para que tu web lo active. En este caso, cualquier versión de php lo soportará, es indiferente la versión de PHP que usemos así que todos nuestros clientes pueden disfrutar de la velocidad de HTTP/2.

¿Qué es el HTTP/2? Es el mayor avance en el protocolo HTTP desde hace 15 años. Puedes ver en enlace de Wikipedia que lo explica detalladamente.

Si tu web está actualizada y puedes habilitar PHP7 y activas el HTTP/2 simplemente creando un certificado SSL gratis que ofrecemos, te aseguramos que la velocidad será de al menos 3x más. Prúebalo y nos cuentas.
Si no tienes activado el certificado SSL en tu web, puedes hacerlo fácilmente siguiendo nuestro tutorial:

Instalar Certificado Let’s Encrypt cPanel

 

LITESPEED CACHÉ

Uso de una nueva Caché dedicada para WordPress.

Otro plus añadido a nuestros alojamientos. Ahora podremos usar en nuestros servidores la mejor caché que existe en todas las pruebas de rendimiento. Pero a esto le dedicaremos un capítulo aparte para no aburrirte más en este post 😉  (Abajo encontrarás en enlace al tutorial)

P.D. Hemos cambiado también de proveedor de Reglas de Modsecurity. Si notas que tu ip es baneada en el servidor al hacer cualquier operación en tu web, saca un ticket de soporte para que deshabilitemos esa regla y no te banee más.

 

LiteSpeed Cache para WordPress

Servidores LiteSpeed con HTTP2, PHP7 y LiteSpeed Cache
5 (100%) 1 vote

Deja un comentario